Top Earners This Week
mishteuse Points: 945 Lv 20
bends9s Points: 605 Lv 13
Edgy_Beneviento Points: 582 Lv 12
Amatoris Points: 558 Lv 30
5 Points: 557 Lv 29
Cannith Points: 555 Lv 30
KamikazE_Mind Points: 553 Lv 30
DarkteK Points: 552 Lv 13
kaktyccc Points: 552 Lv 11
gaijinDave Points: 548 Lv 21

10 Year Redesign Bug Reporting

  • 299

Alienware Arena just underwent a major design change.  We've added some new features and removed some antiquated ones.  Of course, this means that some issues occasionally pop up with a new system once a million people start using it.  If you experience issues, including bugs, typos, or just cant find something, please let us know below.  

Please leave as much information as possible to help us better address the issues: 

  1. Issue Description
  2. Exact URL of where the issue is (or isn't) located.
  3. Browser
  4. Workarounds?

We hope, overall, the new site is up to snuff with you guys.  No one likes change, so we're sure we'll get the standard complaints.  Just keep them civil please.  

UPDATES! View this thread for updates that have been deployed.  More coming.  

Replies • 136
hkzTe8x.pngBorders are overlapping in Borders section of account personalization. Happens at <>. Occurred on Firefox 68.0.2, did not attempt on another browser. Persists after toggling off extensions and Firefox built in content blocking.

Main page Clicking on the daily quests goes nowhere. Chrome 64-bit Of course I did not think the old link would work. I cannot find a work around. It seems Chrome does not like this as IE leads to a post.

Cannot edit my post, It seemed to fix itself after I did a login cycle.

  1. Issue Description: There are no timetags in all posts. Now I couldn't know the post is 2 minutes ago or 1 day ago.
  2. Exact URL of where the issue is (or isn't) located. : all alienwarearena posts.
  3. Browser: Firefox 68.0.2 and Chrome 76.0.3809.100
  4. Workarounds? Both browser are the same. I don't know when the users post their articles after 10 Year Redesign.

I don't want to sound negative and I mean no disrespect for anyone involved, but for me, new theme sucks a little. (well, to be perfectly honest more than a little) I mean, it is ill conceived at best. 


Sure, it does look nice and slick at first glance, but the old one was both practical and perfectly functional. Which more than I could say about this hot mess we have right now. (If something ain't broken, why fix it? And why fix it with more broken parts?) It somehow manages to feel like both heavily stripped down and unnecessarily complicated at the same time, which baffles me to no end. 

For example, I was going to create a topic about this, a review of the new theme if you will, and after looking for a button to create a new topic for about 5 minutes, I just gave up and decided to post here instead. Maybe that was intentional, but still, it sucks a little. New isn't always the best, and I simply cannot shake the feeling this isn't the Alienware Arena I knew and loved all these years. It sure doesn't look or feel like it. Why alienate your userbase like this? Why go with something less user friendly?

As for removed features, why remove them at all? What I loved most about this place was, it was really diverse. Sure, some places were used to farm arp, which is understandable given how difficult it is to gather arp is (insanely so even with farming), but it seems like while trying to prevent people from doing that, forums section which were already too simple to be anything of substance, were over simplified instead of being improved. While the argument could be made it was just streamlined to be more efficient, no one asked for that. No one wanted that. What people wanted was  improvements and I feel like it badly missed the mark.


As with all things, I am sure there will be some who loves the new theme and removed features, just as some who hates it with great passion, but either way time will tell. As for me, I will come every now and then as always. But it just wont feel the same.


Just a little update, posting again because I can't edit my post.


First of all, I am sorry if this is in the wrong section, I just felt like it was relevant and I couldn't create a new topic at first.


But after refreshing the page on forums like 10 times in a row, a white bar magically appeared on the right side saying "CREATE THREAD" which wasn't there before for whatever reason. Good thing that it fixed itself, bad thing is that I can't bring myself to like it. But I am fully aware this is something I have to deal with myself.

The daily 20 up voting post still works but no where does it show it as a daily with how many you have currently up voted.

I can't find out, how to organise forums by latest topic on top, not by latest reply?

  1.  I think I'm missing a week's or two worth of ARP. I was at 2900-something, a bit less than 100 away from Elite tier. After the redesign, I'm down to 2758. Did anyone else get rolled back?
  3. Google Chrome (64-bit) v76.0.3809.100
  4. No workarounds. Tried to delete cookies and reset cache, though. Even tried incognito log in to see if it would refresh.